Ratojen lisääminen

Tapahtuman järjestäjänä sinun on lisättävä tapahtuman radat. Radat voi tuoda Liveloxiin IOF XML-muodossa, joka on vakiomuoto ratojen ja rastien vientiin. Lisäksi tuettuna on OCAD:n ja Purple Penin ratasuunnittelutiedostot sekä ratatulostetiedostot PDF- ja SVG-muodossa.

Kun menet ensimmäisen kerran tapahtuman Radat -osioon, ratoja ei luonnollisesti ole käytettävissä. Sinun on ensin luotava tiedosto, joka sisältää tarvittavat tiedot.

Ratatiedostojen vienti OCAD:sta

OCAD 9:ssä ja uudemmissa on tuki ratatiedoston viemiseen IOF XML-muodossa. Seuraava kuvaus koskee OCAD 11:tä, mutta sama periaate toimii myös versiossa 9 ja 10. Tässä oletetaan, että tunnet OCAD:n ratasuunnittelun ja radat ovat jo valmiit.

  1. Avaa ratasuunnittelutiedosto OCAD:ssa.
  2. Jos ratasuunnittelutiedosto on georeferoitu, on helpompaa sovittaa kartta seuraavissa vaiheissa, mutta se ei ole välttämätöntä. Georeferoi ratasuunnittelutiedosto valitsemalla valikosta Kartta > Valitse mittakaava ja koordinaattijärjestelmä. Varmista, että taustakartan oikea koordinaattijärjestelmä on valittu. Paina Valitse -painiketta valitaksesi koordinaattijärjestelmän. Yleisin Ruotsalaisissa suunnistuskartoissa käytössä oleva on SWEREF 99 TM , katso alla oleva kuvakaappaus.

  3. Valitse valikosta Ratasuunnittelu > Vie > Radat (XML, IOF-versio 3.0). Määritettyyn sijaintiin luodaan tiedosto, jossa on rastien sijainnit ja radat.

OCAD 8:sta puuttuu toiminto viedä IOF XML-tiedostoja. Tässä tapauksessa voit sen sijaan käyttää ratasuunnittelutiedostoa alla olevan ohjeen mukaan.

Ratatulostetiedostojen vienti OCAD:sta

OCAD:ssa on mahdollista leikata rastiympyröitä ja rastiväliviivoja niin, että tärkeät kartan yksityiskohdat eivät peity. Tämä lisää luettavuutta ja antaa osallistujalle laadukkaan ulkoasun. Rastien järjestysnumeroita voidaan myös siirtää, mikä on hyödyllistä, kun rastit ovat lähekkäin. Tätä tietoa ei sisällytetä IOF XML-tiedostoihin, jotka sisältävät vain rastien koordinaatit ja ratoihin kuuluvat rastit.

Livelox voi luoda radan ulkoasun IOF XML -tiedostojen perusteella, mutta ilman leikattuja rastiympyröitä ja rastiväliviivoja, kiellettyjen alueiden merkintöjä ja rastien järjestysnumeroiden muutettuja sijoitteluja. Jotta radan ulkoasu on täsmälleen sama kuin ratasuunnitteluohjelmassa, sinun tulee viedä vektorimuotoinen radan tulostetiedosto PDF- tai SVG-muodossa jokaiselle radalle. Tätä ei tarvitse tehdä, mutta kuten sanottu, se tekee radasta paremman näköisen. OCAD 9 ja uudemmat tukevat ratatulostuksen vientiä PDF-muodossa. OCAD 10 Professional, OCAD 11 Professional ja OCAD 12 ja uudemmat tukevat SVG-muotoisen ratatulostuksen vientiä. SVG-tiedostojen luominen on samanlaista kuin PDF-tiedoston luominen:

  1. Piilota ratasuunnittelusymbolit, joita et halua nähdä ratatulosteessa. Varmista erityisesti, että rastimääritteet on piilotettu, koska muuten Liveloxilla voi olla vaikeuksia sijoittaa ratatulostetta. Napsauta hiiren kakkospainikkeella symboleja oikealla olevasta symbolipaneelista ja valitse Piilota.
  2. Tarkista, että taustakartta ja kaikki taustakuvat on piilotettu. Valitse valikosta Taustakartta > Piilota kaikki.
  3. Tarkista, että näyttötilaksi on asetettu Normaalitila. Valitse valikosta Näytä > Normaalitila.
  4. Valitse valikosta Tiedosto > Vie tiedostoksi.
  5. Vie -paneelissa asetusten tulisi olla alla olevan näyttökuvan mukaisesti. Viennin mittakaavan tulisi olla sama kuin kartan mittakaava. Muista säätää kartan kokoa siten, että kaikki kohteet ovat mukana. Paina Vie -painiketta, kun kaikki valinnat on tehty. Jos saat viestin, jonka mukaan kartta on vietävä rasterimuodossa, et ole onnistunut piilottamaan taustakuvaa edellisissä vaiheissa. Jos näin on, peruuta ja palaa takaisin korjaamaan tämä.

    Valitse radat, joille ratatulosteet tulisi tehdä. Älä sisällytä < Kaikki rastit >. Kun olet painanut OK -painiketta, voit valita, mihin kansioon haluat tallentaa ensimmäisen tiedoston. Älä muuta tiedoston nimeä. Yksi tiedosto kutakin rataa kohden luodaan kansioon, jonka määritit painamalla Tallenna -painiketta.

Jos käytät OCAD 8:ta, et voi viedä SVG- tai PDF -tiedostoja. Mutta tämä voidaan kiertää seuraavasti. Varmista, että sinulla on asennettuna ohjelmisto, jolla voidaan luoda PDF -tiedostoja, kuten CutePDF Writer. Varmista OCAD 8:ssa, että taustakartta ja kaikki taustakuvat on piilotettu, ja valitse sitten valikosta Tiedosto > Tulosta. Valitse avautuvassa tulostusvalintaikkunassa PDF-tulostusvaihtoehto. Valitse Kartan osa ja merkitse kartan osa seuraavasti: Merkitse vietävä reitti ja paina Tulosta -painiketta. Jokaista rataa kohti tehdään PDF-tiedosto.

Ratasuunnittelutiedostojen ja ratatulostetiedostojen lataus

Kun tiedostot on viety OCAD:sta tai muusta ratasuunnitteluohjelmasta, ne tulee ladata Liveloxiin. Kohdassa Radat on painike Valitse ladattavat tiedostot, jota tulee painaa.

Seuraavat tiedostomuodot voidaan ladata:

  • IOF XML -tiedostot, versiot 2.0.3 ja 3.0 (.xml)
  • PDF -tiedostot (.pdf)
  • SVG -tiedostot (.svg)
  • OCAD 8, 9, 10, 11, 12, 2018 ja 2019 (.ocd) -ratasuunnittelutiedostot
  • Purple Pen (.ppen) -ratasuunnittelutiedostot

Valitse kaikki viemäsi tiedostot, sekä ratasuunnittelutiedostot (ne yleensä päättyvät .Courses.xml, jos se on OCAD:sta viety IOF XML -tiedosto), että ratatulostetiedostot, jos sellaisia on. Voit valita useita tiedostoja kerralla. Kun tiedostot ladataan, tietoja voidaan tarkastella neljässä välilehdessä.

Radat -välilehti

Täältä näet tiedostoon sisältyneet radat ja rastien järjestyksen. Rata voidaan poistaa painamalla roskakori -painiketta. Vihreä valintamerkki tarkoittaa, että rataan on liitetty vektorimuotoinen ratatuloste.

Rastit -välilehti

Täällä näet luettelon käytetyistä rasteista ja niitä käyttävistä radoista. Vie hiiri rastin päälle näyttääksesi sen sijainnin kartalla.

Ratatulosteet -välilehti

Täällä näet kaikki ladatut ratojen tulostetiedostot. Voit määritellä radan tulostusmittakaavan ja mihin rataan ratatuloste yhdistetään. Normaalisti nämä vaihtoehdot valitaan jo etukäteen.

Esikatselu -välilehti

Täällä voit tarkistaa, että rastit ja radat ovat päätyneet oikeaan paikkaan. Ylimpänä ylhäällä on kaksi valintaluetteloa. Ensimmäisessä valitset, mikä rata näytetään. Voit myös valita Kaikki rastit. Toisessa valitset taustakartan: joko ladatun kartan tai satelliittikuvan Google Mapsista. Lähennä ja loitonna hiiren vierityspyörällä. Voit myös napsauttaa ja vetää karttakuvaa siirtääksesi sitä.

Jos ladattua ratasuunnittelutiedostoa ei ole georeferoitu, esimerkiksi kun olet ladannut sen OCAD 8 -tiedostona, sinun on vedettävä “rastipilvi” manuaalisesti oikeaan paikkaan hiiren avulla. Voit tehdä sen esikatselunäkymässä. Noudata annettuja ohjeita.

Tallenna

Kun olet varmistanut, että kaikki tiedot ovat oikein, paina Tallenna -painiketta. Jos tapahtumassa ei ole sarjoja, saat kysymyksen, jos haluat luoda sarjat näiden ratojen perusteella. Tämä on varsin kätevää pienissä tapahtumissa, joissa on usein yksi sarja per rata.

Jos tapahtumassa on hajontaratoja, kuten esimerkiksi viestikilpailuissa, tai ratoja, joissa on silmukoita tai perhosia, sinun on yhdistettävä useita ratoja kyseiseen sarjaan. Lue lisää viesteistä ja useista radoista per sarja.

Jos haluat tehdä muutoksia ratoihin, vie uusi ratasuunnittelutiedosto ja uudet ratatulostetiedostot ja lataa ne uudelleen. Uudet tiedot korvaavat olemassa olevat tiedot.

Lisää tietoa

Koppling till Eventor inaktiverad under helgen
Svenska Orienteringsförbundets IT-system Eventor dras med driftproblem. I syfte att lokalisera problemet har man valt att stänga av kopplingen till Livelox under hela helgen. Det innebär att du som Livelox-användare kan uppleva problem med inloggning och automatisk koppling av rutt till aktivitet, samt få felmeddelanden vid administration av aktiviteter.

Vi ber om ursäkt för denna situation, som tyvärr ligger helt utanför vår kontroll. Läs mer hos SOFT.